C-Max Owners Club banner
1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
My front washers arn't working, when you push button on stalk, you can here it wirling as normal, but nothing out the jets, bottle is full, removed bonnet sound proofing and removed tube from jets, and still not working when pressed (thought jets might be blocked). Is the pump gone, as it sounds normal?
 

·
Registered
Joined
·
232 Posts
Dazza, Hi. Well i had this on my mondeo last year, the pump was wiring but not pumping. What caused it was a build up of algee slime in the bottom of the washer bottle, a skin had formed over the intake of the pump. Just needed a clean up. The pump should just pull out. once out stick a hose pipe down the washer bottle top up and give it a good hosingNow i use goodquality screen wash. Its worth a look and costs nothing Edited by: marshal
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Thanks for that, went straight out and removed wheel and linning and that was the problem, the intake for the pump was covered in a slime, one good clean and rinse and it now works again, thanks for that.
 

·
Registered
Joined
·
232 Posts
Thats a job well done

Just for info. Ive tried halfords screen wash and after a week it smells like pond water. I now use genuine ford sceen wash. Thats been in the car now for about 3 weeks and still smells as fresh as day one. I know its a little more expensive but it does the jobEdited by: marshal
 

·
Registered
Joined
·
29 Posts
I had the same problem with my windscreen washer bottle on my 2003 Cmax and had to put a new pump on it in 2006 because despite cleaning all the slime, the pump didn't want to pump like it used to.The same problem has just started againso I'll have to take it all apart and buy a new pump. Looks like each pump last about 3 years!!<?: prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />

I have been using the Halford screen wash so it might be worth changing it now to something better.
 
1 - 6 of 6 Posts
Top