C-Max Owners Club banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I found the problem with the car smelling of exhaust fumes, that I posted earlier, it was 2 injectors leaking i could hear a high compessed leaking air sound coming from the engine and located it to the injector, and I found a pool of what looks like diesel at the bottom of the injector. The problem starts from there on, as I went to remove the wet injectors, I un did the 2 alan screws that held the injectors in place and before that I unclipped the lead and the fuel pie that goes to the injector. Unfortuanetly the injector would not budge it was solid, I did use reasonable measures without damaging the injector, but to no avail, I therefore proceeded to put it all back together to take it to the garage for the experts to sort out. On completion I started the car up it ran for about 5 seconds then cut out, and now will not start up at all, I did not lose any diesel or pressure when I undid the fuel pipe that connects to the injector so that would rule out it need bleeding. In the meantime I have disconnected the battery and hope it resets itself, other than that I'm at a loss, what have I done wrong? please anyone can you please advise me? I'm all eyes and ears!!!!
 

·
Registered
Joined
·
6 Posts
I found the problem with the car smelling of exhaust fumes, that I posted earlier, it was 2 injectors leaking i could hear a high compessed leaking air sound coming from the engine and located it to the injector, and I found a pool of what looks like diesel at the bottom of the injector. The problem starts from there on, as I went to remove the wet injectors, I un did the 2 alan screws that held the injectors in place and before that I unclipped the lead and the fuel pie that goes to the injector. Unfortuanetly the injector would not budge it was solid, I did use reasonable measures without damaging the injector, but to no avail, I therefore proceeded to put it all back together to take it to the garage for the experts to sort out. On completion I started the car up it ran for about 5 seconds then cut out, and now will not start up at all, I did not lose any diesel or pressure when I undid the fuel pipe that connects to the injector so that would rule out it need bleeding. In the meantime I have disconnected the battery and hope it resets itself, other than that I'm at a loss, what have I done wrong? please anyone can you please advise me? I'm all eyes and ears!!!!
I usually have my cars detailed on weekends at home but I had to drive that weekend to a cousin’s wedding. Made a last minute call and I was so glad that they were able to accommodate me. True to their tag line, Signature Detailers is the best mobile auto detailing service in the Washington DC area.
www.signaturedetailers.com
 
1 - 5 of 5 Posts
Top