C-Max Owners Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
My 04reg C-max 1.6Tdi Auto lost Torque and Power.
1 Driving back from Crail in Scotland negotiating the Edinburgh ring road came of at A72, the car lost total torque and power. It was very difficult to pull away but managed to maintain progress until Peebles where I called in at Ford Agent David Harrison. They carried out diagnostic and they cleaned the MAF and IAT sensors of oil contamination and checked the turbo and actuator both of which were OK. Checked for PCM updates – all correct and finally cleared the codes. Total cost £60 for one and half-hours work.
2 The Garage, David Harrison of Peebles, was very helpful looking into the problem without delay. I can only praise them for being so efficient. If I took the C-max in at my local Ford Agent it would cost me double and I would have to wait a good few hours just have the problem to look at.
3 Question does anybody know where the IAT sensor is located?
4 Has anybody experienced anything similar?
PS three months previously had new EGR valve and MAF fitted
 

·
Premium Member
Joined
·
3,966 Posts
I'm presuming that IAT is Inlet air temperature and by them cleaning for oil that it is somewhere close to the turbo feed in the inlet manifold.

Did the work they did cure the problem?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Yes problem cleared. but engineer said that the fault may happen again may be in a month or year or some time in future - anyway I drove 400 miles on motorway without further difficulty.
IAT still not sure where it is located
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Have found out that IAT and MAF sensors are combined in the plastic moulding assembly which is located between the Air Filter box and the rubber moulding fixed to the turbo. The sensor can not be individually replaced but have to purchase the whole plastic assembly priced about £120.
 
1 - 4 of 4 Posts
Top