C-Max Owners Club banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, everyone, I have had my C-MAX 1.6 TDCI for about 6 months now. Although its done over 100k miles its costing me a fortune. I have read loads on this forum about the alternator packing in. I have this problem now but not sure if its the altenator ,battery, both, or even somthing else. The battery went very low so i got all the symtoms on the dash ie, abs steering failure then complete engine failure (wont start) When i put the battery on charge the car runs fine for a short while until battery drains again. I have tested alternator and it does have an output, Also no indication on dash of any problem. I have checked the alternator clutch and the inner part is turning fine so could the alternator still be faulty? The battery is a motorcraft with the little round condition indicator. This was red, i am currently charging the battery off the car (i have my radio code lol) this indicator is now turning slightly green/yellow round the edge but still mostly red. I would really appreciate your views on these problems, cheers. Edited by: Bellman
 

·
Premium Member
Joined
·
2,364 Posts
Hi Bellman,it does seem to suggest the alt has gone bad,that`s why the batterry won`t hold a charge.You are doing the right thing charging the batteryas long as you give it a trickle charge and leave untill fully charged.
How long has the battery been in? & what age is your car? Do you know if it`s had an alt change at all?
MM
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks for your reply. The car is a 2004, its possible the battery is the origional one but not sure as i have had the car 6 months. I cannot see a date of maufacture on batt . Alsothe battery has been charging about 5-6 hours now and has bubles coming up (it has screw of tops) Same with the alternator it actually looks pretty new but again cannot tell age. I just hope its not the smart charge system. When it stops raining i will remove the alternator and try get a look inside it.
 

·
Premium Member
Joined
·
2,364 Posts
Pretty sure it`s not smart charge.I have a 53 plate 2004 2.0 TDCI with 74,000.I had to change the alt not long after I got it (22 months ago) & has been fine since.I do give the battery a trickle charge every 3 months as I don`t do great distances,only short stop/start runs with the occ blast to Sheffield & even rarer run to Devon.I have found if I don`t run it for a week (especially when the weather`s cold) I do find it turns over slowly ,but is ok after that (then I`ll charge it as a matter of course).
Best of luck
MM
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I changed the alternator today and all iswell up to now. Opted for one from the local ford dealer £160 exchange (Lookers) I could have however got one from a local factors for £118. This C-max also only does short trips, I have one of those 12v solar panels that plug into the lighter so will start using it. At least the dash has plenty of room for the solar panel to sit on, ideal for trikle charging.
Edited by: Bellman
 

·
Registered
Joined
·
336 Posts
hmm might be an idea for my wifes car, a renault scenic that has loads of electrics and she does a mile to the shops and a mile back might keep the battery topped up.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top