C-Max Owners Club banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi

I have been a lurker on the site for a while and have found the advice from members here very helpful previously, but have beenstuck for the solution to a particular problem, and am hoping you can help me.

I have a 54 reg focus 2.0 tdci zetec, had it from almost new ( 50 miles ) and apart from creaking plastics and random low fuel warnings it has been more or less ok till this last 18 months or so. We started with very occasionally the enginelosing powerat junctions/roundabouts - not revving past 500ish for 2 mins - and were able to identify ( eventually ) that it was the egr. In the meantime we replaced the alternator as well. The egr fault only seemed to happpen every once in a blue moon, but last month it started to happpen every day so we picked up a new egr from the local ford dealer and my husband ( was a mechanic for 12 years ) fitted it - we took it to fords the next day for the ecu to be re programmed. My problem now is it still runs like a sack of sh*t for want of a better phrase..... It misses/misfires at approx 2000 revs in first and I don't feel it is as responsive
as it used to be, hubby is working away at the moment and goes into a depression when I bring it up at the thought of having to part ex it for something newer/better!

Can you give him some inspiration!

Thanks
SlummyMummy
 

·
Premium Member
Joined
·
3,966 Posts
As diesels don't have ignition I'd suggest a starting point is air in the fuel lines a (partially)blocked filter (various) fuel pressure / temperature sensors and finally the injector pump (in increasing cost terms)

Does it misfire at the same engine speed in any other gear as well or can you get it to misfire in say 2nd or 3rd at a higher engine speed (reasoning being that it might show fuel starvation)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks Richard, I do know that hubby changed the fuel filter and serviced the car at the same time as the egr was replaced, he should be back at the weekend so I will grill him about the other suggestions, I'll let you know how we get on - Cheers
 

·
Registered
Joined
·
3 Posts
Hi

I have a 2004 2.0tdci and seem to have exactly the same problem. At approx 1900/2000 rpm the engine hesitates or , on a couple of occasions,has stoppedcompletely. Diagnosed as egr problem - had new one fitted but no better.
The problem onlybegan after once stalling the car and immediately trying to restart it. The engine would not run at more than tickover speed. Eventually I left it switched off for 5 minutes and it started and ran OK. However, after that I have had this recurring runnung problem. Could this help to pinpoint the cause?

Any help gratefully received!

Geoff
 

·
Premium Member
Joined
·
2,364 Posts
A follow on fault after the egr is the turbo solenoid valve,this can cause the symptoms you have.
Not cheap & dealer fit job too

MM
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks Metalmicky - hubby will be crying into his coffee if that's the case - it is only in 1st or second gear that it hesitates...he was thinking along the lines of a sensor - I think it is time he reaquainted himself with his old colleagues at the volvo dealership where he used to work - I believe that they use/used this engine in volvos and their diagnostics are compatible! Cheers
 

·
Registered
Joined
·
29 Posts
we had same kind of problem ,it was one of the hoses had a slight split in it,it felt sluggish at chugged when pulling away at junctions
 

·
Registered
Joined
·
39 Posts
Been reading this through. Our Cmax is on it's 2nd EGR valve and seems to now have destroyed this one. I've disconnected the EGR unit and apart from the CEL being on it seems to drive fine.... Anybody know how big a job it is to replace on of these? And what's the craic about getting the ECU recoded?.... for a new EGR unit?!
 

·
Premium Member
Joined
·
2,364 Posts
When mine went I got a quote from a brilliant independant garage by me.Took the car in & 1/2 later,they were on the phone saying they were so sorry,but they could not do the job.When I went back to pick the car up they said,yes they could put the egr valve on,but the ecu needed to be reprogramed at a dealer so it can recognise the new valve.I did go to a dealer & their price was £310 inc vat.The independant was going to do it for under £270.
I have had another electrical problen & a local sparkie (brilliant guy) do the work & I asked him about the egr needing programming into the ecu & he said they do as otherwise it will be set wrong & not operate correctly & need replacing again.
MM
 

·
Registered
Joined
·
39 Posts
Hmmm. I've disconnected it for now. Will this cause any further problems? (and sorry this is a duplicate post - I couldn't find this thread originally!). Will look into get it changed eventually. Is there no indy garages out there with the correct software that can do the recode?... I'm an ex-Audi driver and every grease monkey with a laptop could do a recode to some degree....Does it have to be Ford....Anybody?!
 

·
Registered
Joined
·
24 Posts
I have the same (130 bhp) engine in my Mondeo and on MEG (Mondeo Enthusiast Group)website there is loads of posts on this engine hesitating around 1700-2000 rpm and stalling when not used to the car/engine, it is just considered to be the engine rather than a fault, just needs a few more revs when pulling away, not due lack of torque as it has plenty, just a quirk of the engine. Obviously if it is not just slight hesitation there could be something else causing issues...
 

·
Registered
Joined
·
39 Posts
There's no hesitation and it's def. the egr that's goosed. As I said, it's disconnected now. Car's running great, even better mpg! I think when we get it fixed I'm gonna keep it unplugged until MoT time, it'll save the damn thing breaking every 18months.
 
1 - 13 of 13 Posts
Top