C-Max Owners Club banner
1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I own the 2.0TDCI Focus Cmax 2004 Ghia. I am currently having intermitant issues with acceleration at 2000rpm (jerky) & flat spots at 3000 to 4000rpm. I havetaken itto mylocal garage twice to have the codes read, however the car runs find at idle so no codes are showing. He has stripped down the EGR valve, hoses & injectors with no issues found. I have been running the car for a day with Miller's injector cleaner within the fuel to see if this makes any difference - Not Yet! He recommends to take it to a Ford Dealer for a deeper survey/investigation. Any thoughts before I get ripped off!
Regards,
Mike
 

·
Registered
Joined
·
39 Posts
Oor 2.0tdci has done this too. It's almost definately the EGR mate. I believe it will need to be replaced. By Ford as it will also require recoding.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I looked into the EGR issues on other websites, they state that when you remove these they contain a significant amount of thick sludge which requires removing. Mine is clean - could it still be the EGR?
 

·
Registered
Joined
·
133 Posts
i think it probably is the egr, but once its has been replaced it will need re-calabrating by fords, and there is also a ecu update that they should do that will improve the life of the egr which makes it cycle a couple of times once the engine is turned off to prevent the egr from sticking.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
I have it booked in for 11th Nov, this was their earliest date! EGR valves appear to be a very common fault when your surfin the net for answers. Any ideas on the cost?
 

·
Registered
Joined
·
12 Posts
I've had similiar problems on take off from junctions and stand still, had my baby serviced (filters changed ) has not done it since BUT I have changed the type of fuel I had been giving her.not sure if this has cured the problem but have noticed this on other cars I have had in the past.my baby now only gets shell deisel, had been using a mixture of esso and bp only because they are closer to my home.
 

·
Registered
Joined
·
11 Posts
See 54 plate problems thread. Similar problems paid £775 but this included some radio repair and they only charged me for 6 hours and they had a mechanic on the job for 20 trying to diagnose problems after changing EGR! Mine has just broken again!
Very frustrating take care.
 

·
Registered
Joined
·
4 Posts
I have had slight spluttering problems in lower gears post new EGR valve (12 months ago now) .Have lived with i,t but an engine nut friend recommended Millers injector cleaner also but not tried it yet. I always use supermarket Diesel cos' many people say it's the same as any other supplier??
 

·
Registered
Joined
·
1,190 Posts
bruce said:
I've had similiar problems on take off from junctions and stand still, had my baby serviced (filters changed ) has not done it since BUT I have changed the type of fuel I had been giving her.not sure if this has cured the problem but have noticed this on other cars I have had in the past.my baby now only gets shell deisel, had been using a mixture of esso and bp only because they are closer to my home.

Since I had EGR issues, which is well documented elsewhere, I have kept to Shell Diesel (normal) and so far.... nope won't say it but
 
1 - 12 of 12 Posts
Top