C-Max Owners Club banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone, I have recently purchased an 06 2.0 diesel Ghia C Max, great car but I am experiencing parking sensor problems. I have worked thorough solutions from previous threads with no sucsess.
My sympoms are the sensor on/off switch flashes continuosly and bleeps for 3 secs when selecting reverse gear indicating a fault. I disconnected the rear sensors, fault still present, I cleaned the plugs etc replaced the sensor connectors checked the fault and it was still evident. I checked for a clicking from the rear sensors and all were emiting a click. I then checked the front sensors with 1st gear selected all were clicking ok except the off side inner, (no clicking) with some difficulty I disconnected this sensor fault still evident. Re connected the sensor now no clicking from any sensors, front or rear. I have listened for the clicking prior to disconnecting and doing any work and did not hear any. So is the fault intermittent, have I missed something? I have put a small piece of black tape over the on indicator on the switch so I do not have to look at the flashing. Is there any way to disconnect the switch light as I have not had parking sensors before and will not miss them. Reversing lights work ok as well indicating fuse OK
Any help appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 · (Edited)
Front O/S inner prking sensor replacement

Thanks to previous threads I have now sorted the problem, heres how.
From previous threads listen for a high pitched intermittent sound from each sensor, front & rear. I found my inner drivers side front sensor did not emit any sound. I bought a spare sensor from my local Ford dealer for £37.00 +VAT (they wanted 2 Hrs labour + parts + diognostics) about £200.00 to replace 1 sensor. Heres how I changed the sensor.
1) Unscrew the 6 plastic reaining screws from the plastic baffle at the front of the engine compartment, unclip the back edge of the baffle and remove. You may need to gently prize the screw heads up to engage the threads.
2) Remove 2 spring clips from the black plastic air baffle next to the head light, remove the baffle.
3) You now have access to the sensor, unclip the plug, depress the 2 clips holding in the sensor, difficult but can be done.
4) You may need assistance here, push the inner face of the old sensor intowards the bumper, mine proved difficult so used a bar to gentley ease the back out as well, I think mine was difficult to remove as it was gunged up.
5) Once removed clean the hole in the retaining bracket, it will be easier to push in the new one.
6) Replace in reverse order. I found it easier to reconnect the plug before inserting the new sensor back into the bumper, now pray you diognosed the fault correctly, turn on ignition, if OK the parking sensor switch etc will reset themselves. It took me about 45 minutes to complete.
 
1 - 2 of 2 Posts
Top