Ford C-Max Forum - Reply to Topic
Thread: hello Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-08-2019 10:02 AM
khoaideoquangbinh Me too. Nice to make friend with you
05-30-2019 12:49 AM
[email protected] Thanks Skip. My problem has become more complex. need to turn the key upwards of 10 times to make a connection to start. My cruise control stopped working, clock is all screwed up. Keep getting the same message from the vehicle, wrench icon which indicates a powertrain high-voltage charge system fault. I just bought the car pre-owned from a dealer, so warranty issues direct that they repair. They tried once by resetting some stuff, but that remedy did not last. I checked you tube, google, etc to see if there was any documentation on similar problems and have come up empty.
05-29-2019 12:57 AM
Skip C-max
Quote:
Originally Posted by [email protected] View Post
Hi , I am new to the group. From Maine & just purchased 2015 pre-owned C-Max. Like it so far, but this morning I received a message which indicates a powertrain high-voltage charge system fault. Sounds a bit scary! My battery seems to be OK, meters show it is charging. I do have a problem with the key FOB as at times it will not transmit to lock or unlock the doors. So not sure if one has anything to do with the other. Advice will be appreciated. Thank you. Doug
Doug, there is a “button” battery in the key fob. Go to YouTube for how to open the fob. Easy once you’ve done it once. 🙂. S
05-22-2019 02:25 PM
[email protected]
hello

Hi , I am new to the group. From Maine & just purchased 2015 pre-owned C-Max. Like it so far, but this morning I received a message which indicates a powertrain high-voltage charge system fault. Sounds a bit scary! My battery seems to be OK, meters show it is charging. I do have a problem with the key FOB as at times it will not transmit to lock or unlock the doors. So not sure if one has anything to do with the other. Advice will be appreciated. Thank you. Doug

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome