Hi all - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 5 Old 09-28-2010, 12:35 AM Thread Starter
Junior Member
 
Join Date: Sep 2010
Location:
Posts: 3
We have a 2004 1.8 zetec ghiaand its a great car. However It now has some messages on the dash so I've come here to see if anyone can offer any help from previuos experiences. Thetwo messages are brake light fault and engine system fault with a red dot next to it. Both came on at the same time but the brake lights are working and the engine appears to run fine. The car has all the correct fluids at the correct levels. If any one has any ideas or has had this problem before please let me know.

2004 1.8 zetec ghia
mrmonkeyman is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-28-2010, 07:39 PM
Senior Member
 
Richard G's Avatar
 
Join Date: Feb 2008
Location: Water Orton
Posts: 3,967
I suspect the first point would be to see if there are any fault codes stored




Richard
54 Plate 1.6 TDCI LX ~aspiring to be something else
Richard G is offline  
post #3 of 5 Old 09-28-2010, 09:38 PM
Junior Member
 
Join Date: Sep 2010
Location: Norfolk
Posts: 29
I seem to remember getting a brake light fault indication for a faulty air bag on the 2000 Fiesta Lx I had.
These were expensive to replace
TubaTed is offline  
 
post #4 of 5 Old 09-28-2010, 10:55 PM Thread Starter
Junior Member
 
Join Date: Sep 2010
Location:
Posts: 3
I called the rac who put it on there diagnostics and they said there were no faults, He also said that his diagnostic equipment was not as good as Fords. So I took it to fords for them to have a play with. The mechanic who was going to look into the problem said it maybe one of the brake pedal sensors not working, There are two that must work at the same time, but there were no guarantees until he had pluged it into his laptop. Still waiting

2004 1.8 zetec ghia
mrmonkeyman is offline  
post #5 of 5 Old 01-03-2011, 10:18 PM
Junior Member
 
Join Date: May 2010
Location: Worcester
Posts: 9
did the sensors fix your problem?
Thanks

2004 2.0L petrol Ghia
dstephen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome