Complete epb failure - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 1 Old 05-25-2018, 08:27 AM Thread Starter
Junior Member
 
Join Date: May 2018
Posts: 1
Complete epb failure

Hi- I've got a 2007 zetec 2 litre diesel. I've had a 'lazy' starter motor for a few good months- has always managed to start though. For the past few weeks 'engine system failure' has been flashing up at random times but still the car has been fine. I have gone to start it this morning and it is completely dead- won't even tick over- also showing 'complete epb failure' any advice of what this could be please?
Katecmax07 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
EPB Failure stuartn01 Main Message Centre 6 05-23-2012 08:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome