Wiper problem - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 3 Old 04-09-2012, 03:20 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 1
Wiper problem

Hi all, my C Max 1.6 Zetec was recently the victim of a wiper blade vandal. The passenger side arm and blade was left away from the windscreen, and the blade seem to suffer damage - it wouldn't 'sit' fully on the screen.... the centre area of the blade was a couple of mm high, therefore not wiping properly. I bought a new wiper blade, which sits correctly on the screen, but an area is still not wiping - appears to be the same area as before. I thought that the wiper arm might be damaged, but it appears to be the same as another c max. Also the tension appears to be ok. I'd be very grateful for any advice. Cheers, Nick
micress is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-09-2012, 03:35 PM
Senior Member
 
Richard G's Avatar
 
Join Date: Feb 2008
Location: Water Orton
Posts: 3,967
just try bending the arm slightly so as to get the spring to put a little more force onto the screen and check that the blade is free in the carrier with no ripples




Richard
54 Plate 1.6 TDCI LX ~aspiring to be something else
Richard G is offline  
post #3 of 3 Old 04-11-2012, 10:34 AM
Junior Member
 
Join Date: Apr 2012
Location: Essex
Posts: 20
Yes agree with Richard after all not going to make it any worse.
Not.gotta.clue is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
wiper blades ian08zetec1600petrol Main Message Centre 5 11-06-2011 07:08 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome