Oh no ! Not again !! - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 6 Old 01-23-2009, 08:27 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Location:
Posts: 24
Had what most ghia c-maxes have had and thats "limited ebp failure" and sure enough got a new altenator fitted 2 months ago.

All is well....until today...

After driving about 2 miles the abs light came on and then the "limited epb failure " warning came up.I parked up, and left the car for a while. Started up agian and sure enough the same thing happened again.

Anybody got any ideas????

my local ford want 73+ vat for a full diognostic check and software upload. Or doI go back to the place where I bought the cmax ( which is not a main dealer, its a car supermarket and the car is 4 months out of warranty ) and kick up a fuss??
damien is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-23-2009, 08:55 PM
Senior Member
 
Join Date: Mar 2008
Location: Four Oaks
Posts: 2,364
Are you in the AA or RAC? if so ring them & say your car won`t start,when they come out & it starts,ask them to check your battery & alt.I know it`s cheeky but it`s one way of knowing.The other thing,the alt should have come with 12 months gaurentee,go back & tell them what`s happened,but only if you know from AA/RAC if it is that.



MetalMicky08 is offline  
post #3 of 6 Old 01-23-2009, 08:56 PM
Senior Member
 
Join Date: Mar 2008
Location: Four Oaks
Posts: 2,364
I take it you still have the recipt for the alt & work done?



MetalMicky08 is offline  
 
post #4 of 6 Old 01-23-2009, 09:39 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Location:
Posts: 24
no. work was done under warrany so didnt get any.
damien is offline  
post #5 of 6 Old 01-23-2009, 10:10 PM
Senior Member
 
Richard G's Avatar
 
Join Date: Feb 2008
Location: Water Orton
Posts: 3,967
there ought to be a job sheet for the work with the dealer




Richard
54 Plate 1.6 TDCI LX ~aspiring to be something else
Richard G is offline  
post #6 of 6 Old 01-26-2009, 08:08 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Location:
Posts: 24


new update. drove 60 miles over the weekend and no warnings came up.


drove over the biggest pothole in the world on the way home today and the abs light came on along with the limited epb function. so could there be a loose connection to a abs sensor at one of the wheels???Edited by: damien
damien is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome