loss of power - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 1 Old 04-02-2010, 03:44 AM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: Liskeard C/wall
Posts: 8
Hi Guy's/I am new to this lark but i asked for help this week and cannot remember the chaps name but who ever you are,Thanks!It was regarding the loss of power in the rev range 1000-3000 rpm,after i took the fuel pump out (had to come out anyway) i put the c max on a pal's Snap-on Solus i said EGR frozen ! as soon as this appeared we pulled the egr valve out and the VALVE (penny) fell out,very poor fitting only pressed on,we put it back with a spot of weld on it presto!!! sorted although the egr fault is still there and i have a hesitation at 1000-1300 rpm i did save me a chunk of cash!!!i did have a pump ready but my suppliers took it back the egr valve is 167 + vat retail from the main agent,please if you C maxers out there get any problems with loss of power,poor starting,hesitation have it code read the new snap-on data 9.7 will get into it and will also do live data,a lot of small garages have this kit,I have a sykes reader and am now getting the modis or solus !!!!! I have been in the trade for over 40 years and am not afraid to ask this new ecu controlled stuff is for the younger guy's

fury50
fury50 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome