ESP Not Staying on - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 1 Old 12-22-2017, 12:46 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 1
ESP Not Staying on

Hi Guys

Just bought a 2010 1.8L Ford C-max and i've only had it 2 months and starting to get problems.

The first ( and major) problem is that when I initially bought the car, I was looking through the Menu and pressed the menu button to turn ESP off.
Upon trying to turn it back on however, when I press the button the X to signify that ESP is on will only stay on for 5-10 seconds before turning itself off, whereas beforehand this was a permanent X in the box, I'm pretty sure this means that I have no ESP on at all and driving I can feel it skidding around corners, it honestly feels like I can't trust the car going round any corner at speed

Any help would be appreciated as I'm not a car guy at all, and don't really have money to throw at the car trying to diagnose faults.

I checked to see if it was a simple fuse problem but according to my fuse box diagram, I actually don't have any fuses in at all where the diagrams says I should have 3 ABS fuses.
Martyn470 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS warning light staying on Justy Main Message Centre 2 03-31-2011 03:51 AM
lights staying on billy1975 Main Message Centre 1 01-14-2010 03:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome