do i need new ecu for my car - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 5 Old 01-25-2011, 08:05 PM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location:
Posts: 8
hi hope someone can give me some advice , my 54 tdci has been in garage for 2 wks off the road for4 . started one morn then inafternoon nothing ,started with clickin noise when startin ignigition, garage cant find problem but say it could be ecu thats gone , they have tryed some mechanics that work on electrical side, they say wont touch it cos its a cmax and it would need to go to ford garage to get fixed , i phoned ford and they are saying that its highly unlikely that the ecu is away as they have never had to fit one in cmax , im totally confused i dont know what to do , at moment car not going at all they tryed a new ignition trans something (dont know what it was called,it still didnt start anybody have any idea , guy in ford trying to get me just to trade it for new one for 1500 pound trade incos its not startin

ford focus cmax 54 plate TDCI LX
looby68 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-26-2011, 12:19 AM
Senior Member
 
Join Date: Jan 2010
Location: Staffordshire
Posts: 216
Have you tried a new battery, if there is not enough power in the battery to start the engine, you will get a clicking noise and your headlights might flash, just a thought.

54 Plate 2.0 TDCI Zetec, Panther Black, Xenons, Sony 6CD, ESP & F&R Parking Sensors
xenonman is offline  
post #3 of 5 Old 01-26-2011, 12:41 AM
Junior Member
 
Join Date: Nov 2010
Location: derbyshire
Posts: 12
used to be the soleniod either by,on,or in the starter motor that used to make a clicking noise when key was turned to start the engine,low state of batt charge,or a loose connection between batt,starter,and earth.worth an ask.
tracklayer is offline  
 
post #4 of 5 Old 01-26-2011, 02:37 AM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location:
Posts: 8
thanks guys battery was flat and recharged at garage, just looked up company that can reset ecu, oing to give them a phone ,

ford focus cmax 54 plate TDCI LX
looby68 is offline  
post #5 of 5 Old 01-26-2011, 01:13 PM
Senior Member
 
Join Date: Oct 2009
Location: Chelmsford
Posts: 1,085
Have they tried testing for 12V at the Starter?
Reason for asking is that there is a large Fuse on the main power cable to the Starter ( 150A I think ), if this were blown then the Solenoid would operate ( with a Click ) but Starter motor not actually work.
Ask them to put a live feed directly from Battery to the Main pole on the Starter.
I would 99.9% say the ECU is OK, as its not directly linked to the Starter, if Imobiliser were at fault within the ECU you wouldn't get the Click.

2010 Titanium 2.0 TDCI Panther Black.
kevmond is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome