coolant loss finally solved!! - Ford C-Max Forum
 
LinkBack Thread Tools
post #1 of 1 Old 09-22-2012, 07:43 AM Thread Starter
Junior Member
 
Join Date: Oct 2011
Location:
Posts: 27
coolant loss finally solved!!

The coolant loss on my 2011 c-max tdci , has finally been solved , after more than 6 weeks and 4 visits to dealer ! not to mention over 50 spent on topping up coolant with anti freeze! It was a leak from the coolant supply to the EGR valve !

It appears that it was leaking into the exhaust system ! even evans halshaw said they had never come across this before..

hope that this may help anyone with similar problem .
hobobill is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
coolant loss!!! hobobill Main Message Centre 2 08-08-2012 01:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome