Clock/radio light - Ford C-Max Forum
Reply
 
LinkBack Thread Tools
post #1 of 11 Old 11-27-2009, 11:02 PM Thread Starter
Req
 
Join Date: Nov 2009
Posts: 3
Got my C-Max yesterday and absolutely love it but have a couple of questions.

Are the radio and clock lights supposed to stay on after I've left and locked the car? Seems a bit much. Also the windows seem to fog up while I'm not in the car easier than all the other cars in the car park (and I don't have the front screen heater).

How does everyone find the car on roundabouts and bends. Being on the outside lane going around a bend has never been my most confident part of driving. Of course the C-Max is higher than my last car so some of that is expected.

Req is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-27-2009, 11:18 PM
 
Join Date: Oct 2009
Posts: 2
hi im havin similar problem but my light on the milage stays on started today any info would be helpful
chunkboy is offline  
post #3 of 11 Old 11-28-2009, 08:01 AM
Senior Member
 
Join Date: Jun 2008
Location: Birmingham
Posts: 1,124
The light is supposed to stay on.....no one knows why but it's perfectly normal and no cause for concern.

08 1.8 Titanium C-Max *ST Styled* With Car PC Fitted
Previous:54 1.6TDCi LX Focus C-Max
Gepard is offline  
 
post #4 of 11 Old 11-28-2009, 04:46 PM Thread Starter
Req
 
Join Date: Nov 2009
Posts: 3
Ok, checked it early this morning and it was off. It just must take ages to go off.

Discovered the wiperblade speed. How awesome!

Req is offline  
post #5 of 11 Old 12-01-2009, 03:23 PM
Senior Member
 
Join Date: Sep 2009
Location: Musselburgh
Posts: 470
Yeah the radio and dash display stay on, but mine turns the radio backlight off when I lock the car and leaves the dash display on, find it goes out after about 5-10 minutes or mine does anyway.

Davy


Ford C-Max Zetec 1.6 TDCI - In Moondust Silver
twisterboy is offline  
post #6 of 11 Old 01-10-2010, 11:00 PM
 
Join Date: Jan 2010
Posts: 9
Hmmm interesting one this. I have found that our's does this now and i know for sure that it wasn't doing it earlier today.

I went to swap the cars around on the drive and when re-locking the cmax it seemed the dash backlights for the tripometer, message centre and transmission etc is staying on.

I've gone round the whole car checking the doors are all fully shut, the windows are up, the 'EPB' is on and there are no alert messages but for some reason these lights and only these or staying on.

Its dark outside now so i can see from my bedroom window a nice healthy green glow from an otherwise pitch black driveway.

You say these do go out after a while? Ill keep my eye to this and see, if its still on by the morning or by then if the battery is dead it will be going back to our trusty garage (agaaaaaaaain).


teamSlinky is offline  
post #7 of 11 Old 01-11-2010, 12:00 AM
Senior Member
 
Join Date: Sep 2009
Location: Musselburgh
Posts: 470
Did it manage to go out ok?

I got to admit I'm not a fany of staying on but where I stay it's ok that nobody bothers to notice the car parked up, but I tend to park on main roads a few times during the week and don't like the fact it stays lit for about 10 minutes when I'm not there, but think this is a common Ford thing now as my dad's fiesta does the same thing.

Davy


Ford C-Max Zetec 1.6 TDCI - In Moondust Silver
twisterboy is offline  
post #8 of 11 Old 01-11-2010, 02:14 AM
Senior Member
 
Join Date: Mar 2008
Location: Four Oaks
Posts: 2,364
Mine stays on for about 1min,then all lights go out.
It`s nothing to worry about as allC-Max do it.
MM




MetalMicky ( Mike)

2004 2.0 TDCI Zetec
MetalMicky08 is offline  
post #9 of 11 Old 01-11-2010, 01:56 PM
 
Join Date: Jan 2010
Posts: 9
Well you were right. It took a good 20 mins but eventually the lights went out. Double check it this morning to to make sure battery wasn't dead or anything and it was fine.
Strange that its never done it before (either that or we really didnt notice).
teamSlinky is offline  
post #10 of 11 Old 01-11-2010, 02:19 PM
Senior Member
 
Join Date: Apr 2008
Location:
Posts: 1,190
Does the same on mine as well.
lawe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford C-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
no radio,esp light, flashing parking sencor dale New Member Introductions 1 10-06-2011 06:52 PM
Time on the Radio Clock AndyC Main Message Centre 6 06-05-2011 01:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome